5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

Cisco7200ルータ・エミュレータ 「dynamips」

1 :ぴろりん2006:2006/07/23(日) 10:51:58 ID:iiZM09qD
Cisco7200ルータのエミュレータであるdynamipsのスレです。
CiscoのIOSを使用するため、本物同様の動作をしてくれます。
さらに、仮想ルータ同士を接続してお話させることもできます。

日本語による解説(blog形式なので初めての方は一番下から読んでください)
http://7200sim.blog57.fc2.com/

公式サイト
http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator

公式blog(最新情報はここから)
http://www.ipflow.utc.fr/blog/

707 :anonymous:2008/12/11(木) 00:18:33 ID:???
ありがとうございました

708 ::2008/12/15(月) 23:11:45 ID:???
>>703
俺も気になっているんだが、ノートでやってる連中はいないのか?

709 :anonymous:2008/12/15(月) 23:50:48 ID:???
>>708
ノートPC 3台で10台分のネットワークなら作ったことあるけど

710 ::2008/12/17(水) 00:55:36 ID:???
>>709
1台あたりのノートPCのスペックってどれくらい?
ちょっと自宅で勉強できないので図書館とかにノートPC持ち込んで勉強したいんだわ。

711 :anonymous:2008/12/18(木) 00:37:56 ID:???
>>709
古いThinkPadでやったな、確かThinkPad X40×3台
ただしメモリは1.25GB積んでた
さくさく動くわけじゃないけどな
特に起動時は重いので安定するまで結構時間がかかる

ちなみにPCのスペックが上がっても
それほど仮想ルータの台数は増やせられないな
スペック高いPCでも5,6台が限界だと思え

712 ::2008/12/18(木) 04:27:44 ID:???
5-6台動けばOKです。資格試験の勉強で図書館とか喫茶店で動かすのが目的ですから。。
最近、週末嫁の友達が子供連れて遊びにきたりするので、外で勉強することにしたんです。

713 :anonymous@pl601.nas984.p-aichi.nttpc.ne.jp:2009/01/09(金) 02:35:22 ID:???
ノートでCCIEラボ構築完了。
思っていたよりサクサクと動くよ。
まだ検討されていたらどうぞ。

http://www2.mouse-jp.co.jp/scripts_cart/spec.asp?PROD=0901MB-TW811S-N

問題は出荷までの時間と重量だね。

軽量で済ませたいなら、VAIO Type Zが最適だけど高価なので、
Thinkpad X200あたりを買おうか検討中。

714 :anonymous@p8118-ipbfp204gifu.gifu.ocn.ne.jp:2009/01/11(日) 20:31:55 ID:kxW2gliS
GNS3ってすごく便利なんだけど

インターフェースをno shutすると 対向先がシャットダウンしてても リンクアップしやがるんだが。。。
keepaliveを有効にしても 落ちてくれない。。。

715 :◇ugPD9K.xMA:2009/01/17(土) 18:35:37 ID:CJ7IyfFG
                  /⌒`゙`ヽ-─- 、,-─-、
                 x<⌒`           .、 ゙ヾ⌒ヽ
             /    ,、     ⌒ヽ`ヽ:}  \ `\
              /  __/,'           ヽ:.、  `)  ヾ、
           / ,/ ノ`{`     )_    ノ::   ノ ', リ`゙`
            派  ),)ノレrヽ,人  从 `ヽ、〈::::'   リ`i j
            〉 .ゝュ}.{::し. し ヽ'=ミヽ)(ィヽ_>   / `)〉
              /   、}弋'ソ   !:::し. }ィノ´  ァ 、ノ  ((     書籍代。200万円。
     {ヘ.     〈    人 r  、 弋'tソ(( /`Yイノ
     > `,.:¬ァ‐'‐---'Y(丶 丿   _,ノイ _ノj_ノ       <シスコと同じエミュレーションを
  , -_´/ {:::::::{      `\`T.Tー (イー'´ノ´           リナックスで組んでやるから。
  `ー---‐'ゞ-‐`ー─-、_   У、/´`フ,ィ⌒`ヽ、
                   `ー/、/,'|__/ノ::::::´⌒`ヾ、_
                 /   ○   (.::::      `ヽ,
                   |   |i    ):::::_      )、_
                '、  ○   ゝ`:::::ゝ-く   `  }-、

716 :anonymous@P061198248067.ppp.prin.ne.jp:2009/01/30(金) 01:06:30 ID:???
dynamipsでLinuxのNICデバイス一覧を表示することはできますでしょうか。


717 :p4015-ipgvpnf03osakakita.osaka.ocn.ne.jp:2009/01/31(土) 21:59:54 ID:6TDWOzjs
特俗他

718 :test:2009/03/27(金) 06:06:59 ID:???
test

719 :.:2009/03/28(土) 01:23:28 ID:???
test

720 :anonymous@p3127-ipbf2108funabasi.chiba.ocn.ne.jp:2009/04/19(日) 14:52:26 ID:xKfsKIjL
会社のPCでdynamips動かす場合、NICと紐づけたインタフェースに
本物のデフォゲと同じアドレスを振ったら、障害発生しちゃいますか?

721 :ななし:2009/04/19(日) 16:40:22 ID:???
>>720

やめとけ

722 :anonymous:2009/04/19(日) 18:31:17 ID:???
dynamipsで会社のLANに乗り入れwww
うちの会社なら首飛ぶwww

723 :anonymous:2009/04/19(日) 21:01:03 ID:???
ゲートウェイの乗っ取りとか、普通にネットワークへの攻撃と見なされるだろ

724 :anonymous:2009/04/19(日) 21:05:17 ID:???
同じアドレス振られたぐらいで乗っ取られる設計がクソ

725 :ななし:2009/04/19(日) 21:17:28 ID:???
>>724
現実的には多くの企業ネットワークはその程度だろ

726 :age:2009/04/19(日) 22:59:02 ID:???
むしろ、社内LANの島ハブをループさせるだけで飛ぶんだけどな。。。
800人ぐらいの規模の小さな会社だけど、引越しの時 パートのおばちゃんがやらかしたら 社内LAN全部dでワロタ

情シスから怒られたけど、CCNP持ちの上司が社内LANの設計が悪い!って逆切れしてブチ切れて 対策されました。。


727 :anonymous:2009/04/20(月) 08:36:28 ID:???
>>724
どうしろと。検疫ネットとか使ってポート遮断しろってか?

728 :anonymous:2009/04/20(月) 13:45:29 ID:???
>>727
MACで縛ればおk

729 :anonymous@222.66.230.202:2009/04/20(月) 14:24:53 ID:???
結局、対策するには島ハブ含めた全スイッチの管理が必要じゃね?
それできてるところって情シスにそれなりに人と金を放り込んでくれる会社じゃないか?

730 :_:2009/04/20(月) 16:24:14 ID:???
コスト掛けるくらいだったら、それくらい許容した方が良いというオチ

731 :anonymous:2009/05/14(木) 04:43:55 ID:9stRHwP1
>>714
L1とL2はなぜかずっと生きてるな

732 :sage:2009/06/17(水) 19:18:14 ID:???
>>720
PC起動直後の最初のARPリクエストに
どっちが先に答えるかだな
Dynamipsの方が処理遅延やらで遅れるだろうから
以外と平気な気はする

MACの方が被ったら即障害だな

733 :anonymous:2009/07/11(土) 13:19:39 ID:???
dynamipsでtokyo6to4にIPv6の6to4で接続を試してみたら見事接続できた
IPv6の実験に使えるな
configはこんな感じ

ipv6 unicast-routing

interface e2/0
ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx

interface e2/1
ipv6 address 2002:zzzz:zzzz:1::1/64

interface tunnel0
ipv6 address 2002:zzzz:zzzz::1/64
tunnel souce e2/0
tunnel mode ipv6ip 6to4

ipv6 route 2002::/16 Tunnel0
ipv6 route ::/0 2002:c058:6301::1



ipv6 address 2002:zzzz:zzzz::1/64とipv6 address 2002:zzzz:zzzz::1/64のところの
zzzz:zzzzの部分はインターネット接続のIPv4グローバルアドレスを16進数に変換して埋め込めばOK

734 :anonymous@usr009.bb392-01.udv.im.wakwak.ne.jp:2009/07/13(月) 08:45:36 ID:???
dynamipsで稼動中の機器は、CNAで管理できる?

735 :anonymous@i60-47-23-109.s04.a013.ap.plala.or.jp:2009/08/28(金) 21:59:03 ID:???
メモリ使用量ってどうなってんの
1台で128MB使用する設定になってるのに、何故か2倍使ってる

736 :anonymous:2009/09/03(木) 18:53:50 ID:???
ほしゅ

737 :PIX:2009/10/11(日) 06:14:13 ID:VQN/sF/y
PIX OS 6.3.5を入手したのですが、GNS3で動かす事が出来ません。
どなたかGNS3でPIXを動かしている方、アドバイスを頂けないでしょうか。

[環境]
Windows XP sp3
GNS3 0.6.1(GNS3-0.6.1-win32-all-in-one.exe)
※フルインストール

[設定]
一般設定
 General Settings
   日本語(jp)
   ターミナルコマンド: C:\Program Files\teraterm\ttermpro.exe %h %p /W=%d
   プロジェクトディレクトリ: C:\Program Files\GNS3\Project
   IOS/PIXディレクトリ: C:\Program Files\GNS3\bin
Dynamips
 Dynamips
   プログラムパス: C:\Program Files\GNS3\Dynamips\dynamips-wxp.exe
   作業ディレクトリ: C:\DOCUME~1\test\LOCALS~1\Temp
   ■作業フォルダを児童クリア
   ベースポート:7200     ベースUDPポート:10000  ベースコンソールポート:2000
   ■IOSのゴースト機能を使用する
   ■mmap機能を使用する
   □スペースメモリ機能を使用する
 ハイパーバイザ管理
   ハイパーバイザのメモリ制限: 512
   UDPポート間幅: 100
   ハイパーバイザ管理と関連させる: localhost
   ■インポートするときハイパーバイザを使用する

738 :PIX:2009/10/11(日) 06:23:51 ID:VQN/sF/y
Pemu
 Pemuwr apper
   パス: C:\Program Files\GNS3\pemuwrapper.exe
   作業ディレクトリ: C:\Program Files\GNS3\Temp
   Pemuマネージャと関連させる: localhost
   ■Pemuマネージャを有効にする: 
   ■インポートするときPemuマネージャを使用する
   外部Pemuwrapperのホスト:
 デフォルトPIX設定
   PIXイメージ: C:\Program Files\GNS3\bin\pix635.bin
   キー: 0x00000000,0x00000000,0x00000000,0x00000000
   シリアル: 0x12345678
   Base flash:

が設定となります。

トポロジにPIXを配置して、開始→コンソールを実行すると
「接続を拒否されました」となります。

どうすればPIXを使用する事が可能になるかご教示頂けないでしょうか。
(設定自体はPemuマネージャと関連させる箇所をCOMポート等に
 変更してもNGでした。)



739 :まなか:2009/10/23(金) 20:20:24 ID:???
他のモデルのエミュレータが欲しいな。
なんて。

740 :anonymous:2009/10/24(土) 11:46:16 ID:???
他モデルってたとえばどれよ

741 :anonymous:2009/11/26(木) 17:19:28 ID:dzPSPuHT
カタリストのシュミレータってあるの?

742 :anonymous:2009/11/26(木) 23:35:08 ID:???
無い

743 :anonymous:2009/11/27(金) 11:15:57 ID:E7jibqp6
じゃあぜんぜんつかえねぇじゃん!!

744 :anonymous:2009/11/27(金) 12:27:16 ID:???
つかわなきゃいいじゃんwww

745 :anonymous:2009/11/27(金) 13:13:54 ID:???
シュミレータwww

746 :anonymous@pl448.nas985.p-osaka.nttpc.ne.jp:2010/01/11(月) 19:14:24 ID:???
Dynamips(7200)でRIP動かしてんだけど、あるルータのルートテーブル上にルートAが登録されていて、
それが他ルータから広告されているモノという状態の時に、
Aのメトリックが16であるという広告を受信すると、ルートAの情報がHoldDown状態をすっ飛ばしていきなり
テーブルから削除されてるんですよ。

RIPの資料をみると、
 @メトリック16のパケットを受信
 AHoldDown状態になる

というような事が書いてあるんですが、いきなり削除されてしまうという動作はDynamips特有のものでしょうか?
実機だときちんとHoldDown状態になるものでしょうか。


747 :anonymous:2010/01/11(月) 22:44:05 ID:???
もしHoldDown状態だったら、"ルートテーブル"上にどんな表記で見えるものなのかってのは調べたかな?

748 :746:2010/01/11(月) 23:26:44 ID:???
>>747
>もしHoldDown状態だったら、"ルートテーブル"上にどんな表記で見えるものなのかってのは調べたかな?

はい。それはpossible downですよね?それは確かめました。
例えばあるルートのInvalidタイマーが180秒に達し、HoldDown状態になると、
 Router# show ip route
コマンドで表示されるテーブル情報のそのルート欄にpossible downが表示されていました。

>>746
の場合(Metric 16の広告を受け取る)だとその表示が無く、いきなりルート情報の表示から消えてしまううんです。


749 :anon:2010/01/11(月) 23:47:23 ID:???
show ip routeにそんな表示は無ぇ

って記憶してるんだけど、もうRIPなんて何年も触ってないから自信が無い

750 :anonymous@KD113145034062.ppp-bb.dion.ne.jp:2010/01/17(日) 17:51:45 ID:???
ほしゅ

751 :anonymous:2010/03/30(火) 23:37:06 ID:???
GNS3 0.7 !!!!!!!!
でてた、知らんかった

752 :anonymous:2010/04/17(土) 21:19:54 ID:5ZK6cZGc
VPLSのシュミレーションをしようと考えたけど、
VPLSサポートしてんのCisco7600から何だね。。

753 :anomymous:2010/06/13(日) 00:29:20 ID:Ob35mvSd
738>私も635では動かせませんでした。

754 :anonymous@25.250.100.220.dy.bbexcite.jp:2010/06/18(金) 16:29:07 ID:???
これ見てよ↓
http://livedoor.2.blogimg.jp/agomesu/imgs/4/f/4faec292.png
ばらまこうぜ!


755 :anonymous@r-124-18-207-224.g102.commufa.jp:2010/07/14(水) 00:05:02 ID:h4A1gvyD
bandwidthというコマンドがよくわからないんですけど帯域が64Kと指定があったときに
bandwidth 64000と打ち込めばいいのですか?
また帯域が100Mだった場合はどうすればいいですか?
すみません。どなたか教えてください


756 :anonymous@cthrsm012236.adsl.ppp.infoweb.ne.jp:2010/07/27(火) 21:30:27 ID:UUfRFbFW
bandwidthは単位がkのはず
なので、帯域64kならbandwidth 64でおk


172 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)